import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\+(?=(?:\\s?\\d){7,17}$)\\d+(?:\\s?\\d+){0,3}$";
final String string = "+256897845\n"
+ "+1 232321\n"
+ "+29 2343 2432 43\n"
+ "+555 2356897845\n"
+ "+1245 2356878\n"
+ "+918989784578\n\n"
+ "Must include + Symbol on start\n"
+ "Optional Support up to 3 space Like: +29 2343 2432 43\n"
+ "Minimum 8 Char including + symbol\n"
+ "Max Char 18 digit (3 Space + 4 digit max country code + Plus (+) Symbol + 10 digit max number)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}