use strict;
my $str = '+256897845
+1 232321
+29 2343 2432 43
+555 2356897845
+1245 2356878
+918989784578
Must include + Symbol on start
Optional Support up to 3 space Like: +29 2343 2432 43
Minimum 8 Char including + symbol
Max Char 18 digit (3 Space + 4 digit max country code + Plus (+) Symbol + 10 digit max number)';
my $regex = qr/^\+(?=(?:\s?\d){7,17}$)\d+(?:\s?\d+){0,3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}