$re = '/^\+(?=(?:\s?\d){7,17}$)\d+(?:\s?\d+){0,3}$/m';
$str = '+256897845
+1 232321
+29 2343 2432 43
+555 2356897845
+1245 2356878
+918989784578
Must include + Symbol on start
Optional Support up to 3 space Like: +29 2343 2432 43
Minimum 8 Char including + symbol
Max Char 18 digit (3 Space + 4 digit max country code + Plus (+) Symbol + 10 digit max number)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);