#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"S":"(.*?)".*"IMEI":"(.*?)".*"
Local $sString = "{"ID":"NOKIA-71E1","KY":"59ad728d99","U":"admin","P":"cfa522ec5a","S":"FSH21290288A","23S":"DC8D8A4171E1","N":"5G12-13W-A","PN":"3TG00799ABAA","IMEI":"352778340662308"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")