const regex = /"S":"(.*?)".*"IMEI":"(.*?)".*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"S":"(.*?)".*"IMEI":"(.*?)".*', 'gm')
const str = `{"ID":"NOKIA-71E1","KY":"59ad728d99","U":"admin","P":"cfa522ec5a","S":"FSH21290288A","23S":"DC8D8A4171E1","N":"5G12-13W-A","PN":"3TG00799ABAA","IMEI":"352778340662308"}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}