import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"S\":\"(.*?)\".*\"IMEI\":\"(.*?)\".*";
final String string = "{\"ID\":\"NOKIA-71E1\",\"KY\":\"59ad728d99\",\"U\":\"admin\",\"P\":\"cfa522ec5a\",\"S\":\"FSH21290288A\",\"23S\":\"DC8D8A4171E1\",\"N\":\"5G12-13W-A\",\"PN\":\"3TG00799ABAA\",\"IMEI\":\"352778340662308\"}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}