using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""S"":""(.*?)"".*""IMEI"":""(.*?)"".*";
string input = @"{""ID"":""NOKIA-71E1"",""KY"":""59ad728d99"",""U"":""admin"",""P"":""cfa522ec5a"",""S"":""FSH21290288A"",""23S"":""DC8D8A4171E1"",""N"":""5G12-13W-A"",""PN"":""3TG00799ABAA"",""IMEI"":""352778340662308""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}