// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"S":"(.*?)".*"IMEI":"(.*?)".*"#).unwrap();
let string = "{\"ID\":\"NOKIA-71E1\",\"KY\":\"59ad728d99\",\"U\":\"admin\",\"P\":\"cfa522ec5a\",\"S\":\"FSH21290288A\",\"23S\":\"DC8D8A4171E1\",\"N\":\"5G12-13W-A\",\"PN\":\"3TG00799ABAA\",\"IMEI\":\"352778340662308\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}