use strict;
my $str = '{"ID":"NOKIA-71E1","KY":"59ad728d99","U":"admin","P":"cfa522ec5a","S":"FSH21290288A","23S":"DC8D8A4171E1","N":"5G12-13W-A","PN":"3TG00799ABAA","IMEI":"352778340662308"}';
my $regex = qr/"S":"(.*?)".*"IMEI":"(.*?)".*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}