# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=exchangeRate":)(\d+)\.(\d+)(?=,)/$1,$2/gm;t' <<< "[{\"sendingCurrency\":{\"id\":\"810\",\"code\":\"RUB\",\"name\":\"Российский рубль\"},\"sendingAmount\":6445420,\"sendingAmountDiscount\":0,\"sendingAmountWithoutCommission\":6435520,\"sendingCommission\":9900,\"sendingCommissionDiscount\":0,\"sendingTransferCommission\":0,\"paidNotificationCommission\":9900,\"receivingCurrency\":{\"id\":\"840\",\"code\":\"USD\",\"name\":\"Доллар США\"},\"receivingAmount\":100000,\"exchangeRate\":64.3552,\"exchangeRateType\":\"direct\",\"exchangeRateDiscount\":0,\"profit\":0,\"properties\":{}}]"