import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=exchangeRate\":)(\\d+)\\.(\\d+)(?=,)";
final String string = "[{\"sendingCurrency\":{\"id\":\"810\",\"code\":\"RUB\",\"name\":\"Российский рубль\"},\"sendingAmount\":6445420,\"sendingAmountDiscount\":0,\"sendingAmountWithoutCommission\":6435520,\"sendingCommission\":9900,\"sendingCommissionDiscount\":0,\"sendingTransferCommission\":0,\"paidNotificationCommission\":9900,\"receivingCurrency\":{\"id\":\"840\",\"code\":\"USD\",\"name\":\"Доллар США\"},\"receivingAmount\":100000,\"exchangeRate\":64.3552,\"exchangeRateType\":\"direct\",\"exchangeRateDiscount\":0,\"profit\":0,\"properties\":{}}]";
final String subst = "$1,$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}