const regex = /(?<=exchangeRate":)(\d+)\.(\d+)(?=,)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=exchangeRate":)(\\d+)\\.(\\d+)(?=,)', 'gm')
const str = `[{"sendingCurrency":{"id":"810","code":"RUB","name":"Российский рубль"},"sendingAmount":6445420,"sendingAmountDiscount":0,"sendingAmountWithoutCommission":6435520,"sendingCommission":9900,"sendingCommissionDiscount":0,"sendingTransferCommission":0,"paidNotificationCommission":9900,"receivingCurrency":{"id":"840","code":"USD","name":"Доллар США"},"receivingAmount":100000,"exchangeRate":64.3552,"exchangeRateType":"direct","exchangeRateDiscount":0,"profit":0,"properties":{}}]`;
const subst = `$1,$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);