import Foundation
let pattern = #"(?<=exchangeRate":)(\d+)\.(\d+)(?=,)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[{"sendingCurrency":{"id":"810","code":"RUB","name":"Российский рубль"},"sendingAmount":6445420,"sendingAmountDiscount":0,"sendingAmountWithoutCommission":6435520,"sendingCommission":9900,"sendingCommissionDiscount":0,"sendingTransferCommission":0,"paidNotificationCommission":9900,"receivingCurrency":{"id":"840","code":"USD","name":"Доллар США"},"receivingAmount":100000,"exchangeRate":64.3552,"exchangeRateType":"direct","exchangeRateDiscount":0,"profit":0,"properties":{}}]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1,$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)