$re = '/(?<=exchangeRate":)(\d+)\.(\d+)(?=,)/m';
$str = '[{"sendingCurrency":{"id":"810","code":"RUB","name":"Российский рубль"},"sendingAmount":6445420,"sendingAmountDiscount":0,"sendingAmountWithoutCommission":6435520,"sendingCommission":9900,"sendingCommissionDiscount":0,"sendingTransferCommission":0,"paidNotificationCommission":9900,"receivingCurrency":{"id":"840","code":"USD","name":"Доллар США"},"receivingAmount":100000,"exchangeRate":64.3552,"exchangeRateType":"direct","exchangeRateDiscount":0,"profit":0,"properties":{}}]';
$subst = "$1,$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;