# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*\.)(\d+)\\(?:\n\1\d+\\)+/$1$2\\/gm;t' <<< "D:\folder1\folder2\folder3\Artifact\Artifact-1.1\
D:\folder1\folder2\folder3\Artifact\Artifact-1.2\
D:\folder1\folder2\folder3\Artifact\Artifact-1.3\
D:\folder1\folder2\folder3\Different_Artifact\Different_Artifact-17.1\
D:\folder1\folder2\folder3\Different_Artifact\Different_Artifact-17.4\
D:\folder1\folder2\folder3\Different_Content\Different_Content-2.0\
D:\folder1\folder2\folder3\folder4\Different_Content\Different_Content-2.0\
D:\folder1\folder2\folder3\folder4\Different_Content\Different_Content-2.2\"