use strict;
my $str = 'D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.1\\
D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.2\\
D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.3\\
D:\\folder1\\folder2\\folder3\\Different_Artifact\\Different_Artifact-17.1\\
D:\\folder1\\folder2\\folder3\\Different_Artifact\\Different_Artifact-17.4\\
D:\\folder1\\folder2\\folder3\\Different_Content\\Different_Content-2.0\\
D:\\folder1\\folder2\\folder3\\folder4\\Different_Content\\Different_Content-2.0\\
D:\\folder1\\folder2\\folder3\\folder4\\Different_Content\\Different_Content-2.2\\';
my $regex = qr/^(.*\.)(\d+)\\(?:\n\1\d+\\)+/mp;
my $subst = '$1$2\\\\';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";