$re = '/^(.*\.)(\d+)\\\\(?:\n\1\d+\\\\)+/m';
$str = 'D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.1\\
D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.2\\
D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.3\\
D:\\folder1\\folder2\\folder3\\Different_Artifact\\Different_Artifact-17.1\\
D:\\folder1\\folder2\\folder3\\Different_Artifact\\Different_Artifact-17.4\\
D:\\folder1\\folder2\\folder3\\Different_Content\\Different_Content-2.0\\
D:\\folder1\\folder2\\folder3\\folder4\\Different_Content\\Different_Content-2.0\\
D:\\folder1\\folder2\\folder3\\folder4\\Different_Content\\Different_Content-2.2\\';
$subst = "$1$2\\";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;