const regex = /^(.*\.)(\d+)\\(?:\n\1\d+\\)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*\\.)(\\d+)\\\\(?:\\n\\1\\d+\\\\)+', 'gm')
const str = `D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.1\\
D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.2\\
D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.3\\
D:\\folder1\\folder2\\folder3\\Different_Artifact\\Different_Artifact-17.1\\
D:\\folder1\\folder2\\folder3\\Different_Artifact\\Different_Artifact-17.4\\
D:\\folder1\\folder2\\folder3\\Different_Content\\Different_Content-2.0\\
D:\\folder1\\folder2\\folder3\\folder4\\Different_Content\\Different_Content-2.0\\
D:\\folder1\\folder2\\folder3\\folder4\\Different_Content\\Different_Content-2.2\\`;
const subst = `$1$2\\`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);