import Foundation
let pattern = #"^(.*\.)(\d+)\\(?:\n\1\d+\\)+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
D:\folder1\folder2\folder3\Artifact\Artifact-1.1\
D:\folder1\folder2\folder3\Artifact\Artifact-1.2\
D:\folder1\folder2\folder3\Artifact\Artifact-1.3\
D:\folder1\folder2\folder3\Different_Artifact\Different_Artifact-17.1\
D:\folder1\folder2\folder3\Different_Artifact\Different_Artifact-17.4\
D:\folder1\folder2\folder3\Different_Content\Different_Content-2.0\
D:\folder1\folder2\folder3\folder4\Different_Content\Different_Content-2.0\
D:\folder1\folder2\folder3\folder4\Different_Content\Different_Content-2.2\
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2\\"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)