import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*\\.)(\\d+)\\\\(?:\\n\\1\\d+\\\\)+";
final String string = "D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.1\\\n"
+ "D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.2\\\n"
+ "D:\\folder1\\folder2\\folder3\\Artifact\\Artifact-1.3\\\n"
+ "D:\\folder1\\folder2\\folder3\\Different_Artifact\\Different_Artifact-17.1\\\n"
+ "D:\\folder1\\folder2\\folder3\\Different_Artifact\\Different_Artifact-17.4\\\n"
+ "D:\\folder1\\folder2\\folder3\\Different_Content\\Different_Content-2.0\\\n"
+ "D:\\folder1\\folder2\\folder3\\folder4\\Different_Content\\Different_Content-2.0\\\n"
+ "D:\\folder1\\folder2\\folder3\\folder4\\Different_Content\\Different_Content-2.2\\";
final String subst = "$1$2\\\\";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}