using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([Aa]{2,})r{1}o{1}n{1}$";
string input = @"AAron
aaron
aaaaaaaaaron
aaaaaaaaaronnnn
aaaaaaaaaroooon
aaaaaaaaarrrron
aron";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}