import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([Aa]{2,})r{1}o{1}n{1}$";
final String string = "AAron\n"
+ "aaron\n"
+ "aaaaaaaaaron \n"
+ "aaaaaaaaaronnnn \n"
+ "aaaaaaaaaroooon \n"
+ "aaaaaaaaarrrron \n"
+ "aron";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}