package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([Aa]{2,})r{1}o{1}n{1}$`)
var str = `AAron
aaron
aaaaaaaaaron
aaaaaaaaaronnnn
aaaaaaaaaroooon
aaaaaaaaarrrron
aron`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}