re = /^([Aa]{2,})r{1}o{1}n{1}$/m
str = 'AAron
aaron
aaaaaaaaaron
aaaaaaaaaronnnn
aaaaaaaaaroooon
aaaaaaaaarrrron
aron'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end