$re = '/^([Aa]{2,})r{1}o{1}n{1}$/m';
$str = 'AAron
aaron
aaaaaaaaaron
aaaaaaaaaronnnn
aaaaaaaaaroooon
aaaaaaaaarrrron
aron';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);