using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.{10}$)0*?([1-9][0-9]{0,9}|(?![0-9]*$).*)$";
string input = @"aaaa0000011111
aaaa0000011111111111
bbbb00000a11111
aaaa000002d111";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}