use strict;
my $str = 'aaaa0000011111
aaaa0000011111111111
bbbb00000a11111
aaaa000002d111';
my $regex = qr/(?=.{10}$)0*?([1-9][0-9]{0,9}|(?![0-9]*$).*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}