$re = '/(?=.{10}$)0*?([1-9][0-9]{0,9}|(?![0-9]*$).*)$/m';
$str = 'aaaa0000011111
aaaa0000011111111111
bbbb00000a11111
aaaa000002d111';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);