import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.{10}$)0*?([1-9][0-9]{0,9}|(?![0-9]*$).*)$";
final String string = "aaaa0000011111\n"
+ "aaaa0000011111111111\n"
+ "bbbb00000a11111\n"
+ "aaaa000002d111";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}