import re
regex = re.compile(r"(?=.{10}$)0*?([1-9][0-9]{0,9}|(?![0-9]*$).*)$", flags=re.MULTILINE)
test_str = ("aaaa0000011111\n"
"aaaa0000011111111111\n"
"bbbb00000a11111\n"
"aaaa000002d111")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")