const regex = /(?=.{10}$)0*?([1-9][0-9]{0,9}|(?![0-9]*$).*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=.{10}$)0*?([1-9][0-9]{0,9}|(?![0-9]*$).*)$', 'gm')
const str = `aaaa0000011111
aaaa0000011111111111
bbbb00000a11111
aaaa000002d111`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}