package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+)[^\d]*[^\w]some[wW]ord[^\w]`)
var str = `43434 of someword 12 anything 45 someword 2323 new someword
43434 of someWord 12 anything someWord 2323 new someWord
43434 of notsomeWord 12 anything someWordNotThis 2323 new notsomeWord
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}