use strict;
my $str = '43434 of someword 12 anything 45 someword 2323 new someword
43434 of someWord 12 anything someWord 2323 new someWord
43434 of notsomeWord 12 anything someWordNotThis 2323 new notsomeWord
';
my $regex = qr/(\d+)[^\d]*[^\w]some[wW]ord[^\w]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}