import re
regex = re.compile(r"(\d+)[^\d]*[^\w]some[wW]ord[^\w]")
test_str = ("43434 of someword 12 anything 45 someword 2323 new someword\n"
"43434 of someWord 12 anything someWord 2323 new someWord\n"
"43434 of notsomeWord 12 anything someWordNotThis 2323 new notsomeWord\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")