import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((1?\\d{1,2}|2([0-4]\\d|5[0-5]))\\.){3}(1?\\d{1,2}|2([0-4]\\d|5[0-5]))$|^$";
final String string = "192.168.1.1\n\n"
+ "192.168.255.255\n\n"
+ "8.8.8.8\n\n"
+ "10.10.1.1\n\n"
+ "021.8.8.8\n\n"
+ "8.021.021.8\n\n"
+ "0.0.0.0\n\n"
+ "1.0.0.0\n\n"
+ "100.10.1.1\n\n"
+ "20.200.2.2\n\n"
+ "255.255.255.254\n\n"
+ "266.274.255.0\n\n"
+ "200.249.255.8\n\n"
+ "0.0.0.0\n\n"
+ "1.0.0.0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}