use strict;
my $str = '192.168.1.1
192.168.255.255
8.8.8.8
10.10.1.1
021.8.8.8
8.021.021.8
0.0.0.0
1.0.0.0
100.10.1.1
20.200.2.2
255.255.255.254
266.274.255.0
200.249.255.8
0.0.0.0
1.0.0.0
';
my $regex = qr/^((1?\d{1,2}|2([0-4]\d|5[0-5]))\.){3}(1?\d{1,2}|2([0-4]\d|5[0-5]))$|^$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}