import re
regex = re.compile(r"^((1?\d{1,2}|2([0-4]\d|5[0-5]))\.){3}(1?\d{1,2}|2([0-4]\d|5[0-5]))$|^$", flags=re.MULTILINE)
test_str = ("192.168.1.1\n\n"
"192.168.255.255\n\n"
"8.8.8.8\n\n"
"10.10.1.1\n\n"
"021.8.8.8\n\n"
"8.021.021.8\n\n"
"0.0.0.0\n\n"
"1.0.0.0\n\n"
"100.10.1.1\n\n"
"20.200.2.2\n\n"
"255.255.255.254\n\n"
"266.274.255.0\n\n"
"200.249.255.8\n\n"
"0.0.0.0\n\n"
"1.0.0.0\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")