// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((1?\d{1,2}|2([0-4]\d|5[0-5]))\.){3}(1?\d{1,2}|2([0-4]\d|5[0-5]))$|^$").unwrap();
let string = "192.168.1.1
192.168.255.255
8.8.8.8
10.10.1.1
021.8.8.8
8.021.021.8
0.0.0.0
1.0.0.0
100.10.1.1
20.200.2.2
255.255.255.254
266.274.255.0
200.249.255.8
0.0.0.0
1.0.0.0
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}