#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^a-z\n]+[A-Z]([A-Z][a-z]+(?: [A-Z][a-z]+)*)"
Local $sString = "ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word" & @CRLF & _
"" & @CRLF & _
"ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word Test Words" & @CRLF & _
"" & @CRLF & _
"~~~~@!$%@#% $% %$ Two Word Test Words" & @CRLF & _
"" & @CRLF & _
"Two Word"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")