const regex = /[^a-z\n]+[A-Z]([A-Z][a-z]+(?: [A-Z][a-z]+)*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-z\\n]+[A-Z]([A-Z][a-z]+(?: [A-Z][a-z]+)*)', 'gm')
const str = `ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word
ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word Test Words
~~~~@!\$%@#% \$% %\$ Two Word Test Words
Two Word`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}