$re = '/[^a-z\n]+[A-Z]([A-Z][a-z]+(?: [A-Z][a-z]+)*)/m';
$str = 'ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word
ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word Test Words
~~~~@!$%@#% $% %$ Two Word Test Words
Two Word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);