re = /[^a-z\n]+[A-Z]([A-Z][a-z]+(?: [A-Z][a-z]+)*)/m
str = 'ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word
ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word Test Words
~~~~@!$%@#% $% %$ Two Word Test Words
Two Word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end