import Foundation
let pattern = #"[^a-z\n]+[A-Z]([A-Z][a-z]+(?: [A-Z][a-z]+)*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word
ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word Test Words
~~~~@!$%@#% $% %$ Two Word Test Words
Two Word
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)