package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^a-z\n]+[A-Z]([A-Z][a-z]+(?: [A-Z][a-z]+)*)`)
var str = `ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word
ELIMINATE:TWOS WORD AT THE END OF THIS BUT IGNORE~JUNK~ HELLOTwo Word Test Words
~~~~@!$%@#% $% %$ Two Word Test Words
Two Word`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}