using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)/administrator";
string substitution = @"$1";
string input = @"http://m1.aa.example.com/administrator
http://m2.aa.example.com/administrator
http://m5.aa.example.com/administrator
http://m1.bb.example.com/administrator
http://m2.bb.example.com/administrator";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}