package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)/administrator`)
var str = `http://m1.aa.example.com/administrator
http://m2.aa.example.com/administrator
http://m5.aa.example.com/administrator
http://m1.bb.example.com/administrator
http://m2.bb.example.com/administrator`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}