// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.*)/administrator").unwrap();
let string = "http://m1.aa.example.com/administrator
http://m2.aa.example.com/administrator
http://m5.aa.example.com/administrator
http://m1.bb.example.com/administrator
http://m2.bb.example.com/administrator";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}