package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<date>\S+)\s(?<time>\S+)\sp=(?<id>[\d]+)\su=(?<user>[\w]+)\s\|\s*TASK\s*\[(?<task>[^\]=]*)\s\w+=`)
var str = `2019-03-24 17:57:14,202 p=19455 u=root | TASK [this is the task name msg=Debug message] ************************`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}