// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<date>\S+)\s(?<time>\S+)\sp=(?<id>[\d]+)\su=(?<user>[\w]+)\s\|\s*TASK\s*\[(?<task>[^\]=]*)\s\w+=").unwrap();
let string = "2019-03-24 17:57:14,202 p=19455 u=root | TASK [this is the task name msg=Debug message] ************************";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}