import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<date>\\S+)\\s(?<time>\\S+)\\sp=(?<id>[\\d]+)\\su=(?<user>[\\w]+)\\s\\|\\s*TASK\\s*\\[(?<task>[^\\]=]*)\\s\\w+=";
final String string = "2019-03-24 17:57:14,202 p=19455 u=root | TASK [this is the task name msg=Debug message] ************************";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}